SQLRU.net
Разработка приложений баз данных

Начало » Администрирование ОС » Unix-системы » unzip.zip, но для TLS (Сетевая установка Oracle Linux 8)
unzip.zip, но для TLS [сообщение #1924] Wed, 29 March 2023 13:25 Переход к следующему сообщению
basid в настоящее время не в онлайне  basid
Сообщений: 118
Зарегистрирован: June 2022
Географическое положение: Asia/Irkutsk
Senior Member
HTTPS-истерия дошла до маразма и кое-где репозитории доступны исключительно "с защитой".
Если ставить какой-нибудь дебиан, то можно выбрать http-зеркало, но, например, Oracle Linux предлагает исключительно yum.oracle.com. Репозитории седьмой версии доступны по http, а вот восьмая - уже только https.
Проблема в том, что в промежутке полутора-двух лет что-то протухло и, в результате, невозможно выполнить сетевую установку Oracle Linux 8, а при установке с DVD-образа - невозможно обновить систему.
Если запустить установку, настроить сеть, перейти в одну из "свободных" консолей, то обнаруживается "интересное":
 wget --spider https://yum.oracle.com/
спокойно сообщает, что "remote file exists", а:.
 curl -I https://yum.oracle.com
выдаёт ошибку "invalid padding".
 curl -kI https://yum.oracle.com
ругается "bad signature".
Т.е. "скачать что-нибудь нужное" я смогу. Но вот что именно надо скачивать и куда его добавлять?
Насколько я могу судить:
 grep Digi /etc/ssl/certs/ca-bundle.crt
необходимый сертификат (DigiCert Global Root CA) корневого УЦ - в наличии.
Чего этим сволочам ещё надо-то???
Re: unzip.zip, но для TLS [сообщение #2018 является ответом на сообщение #1924] Fri, 07 April 2023 14:15 Переход к предыдущему сообщениюПереход к следующему сообщению
BlackEric в настоящее время не в онлайне  BlackEric
Сообщений: 318
Зарегистрирован: June 2022
Senior Member
Проверьте что это именно тот корневой сертификат. Может он обновился?
Re: unzip.zip, но для TLS [сообщение #2330 является ответом на сообщение #2018] Tue, 23 May 2023 10:47 Переход к предыдущему сообщению
basid в настоящее время не в онлайне  basid
Сообщений: 118
Зарегистрирован: June 2022
Географическое положение: Asia/Irkutsk
Senior Member
Со своей стороны не делал ничего, кроме обновления до QEMU/Win 8.0. Демоны самоликвидировались.
Не знаю, делали пророки что-нибудь, но правки для TCG эмуляции (некоторых) x86-команд в QEMU8 есть.
Проверять наличие глюков на QEMU7 (в TCG) - лень.
Предыдущая тема: RSA/SHA256 Signature, key ID НОМЕР: BAD
Следующая тема: Книги по Linux
Переход к форуму:
  


Текущее время: Tue Jul 23 05:39:16 GMT+3 2024

Общее время, затраченное на создание страницы: 0.00908 секунд